lunes, 29 de septiembre de 2008

Problema (y solución) al instalar .NET Framework 3.5 (II)

Seguimos con los problemas que nos vamos encontrando al instalar el .NET Framework 3.5, hay que tener en cuenta que las instalaciones se realizan en una gran cantidad de equipos (más de 2.000) con diferentes versiones de Windows y con distintas políticas de administración. Si bien es cierto que la gran mayoría no dan problemas, hay algunos en los que los errores de instalación son bastantes rebuscados, como este caso:


[XX/XX/XX,XX:XX:XX] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
[XX/XX/XX,XX:XX:XX] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.


Esto se debía a que los equipos tenían instalados la versión .NET Framewok 2.0 with Security Updates, que según la knowledge base de Microsoft, da problemas cuando quieres instalar cualquier otra versión del .NET Framework (http://support.microsoft.com/kb/923100/)


El problema añadido es que no permite desinstalar esta versión desde Agregar/Quitar Programas, por lo que es necesario usar una herramienta que haga una desinstalación segura (limpiando el registro y eliminando los ficheros necesarios). Para este caso encontré la .NET Framework CleanUp Utility, creada por Aaron Stebner, que se puede descargar desde este link)

Es muy sencilla de utilizar así que no me voy a detener en explicarlo, lo único que diré es que funciona muy bien y no necesita instalar nada en el equipo en que queremos ejecutarla.


Una vez desinstalado el .NET Framework 2.0 pudimos continuar con la instalación del .NET Framework 3.5 sin problemas.

Relacionado:

Problema (y solución) al instalar .NET Framework 3.5 (I)

4 comentarios:

Anónimo dijo...

NECESITO AYUDA CON NET FRAMEWORK
primero hago click en el paquete de instalacion

se abre y sale un cuadradito que dice que esta EXTRACTING FILES.

luego sale otro cuadradito que dice PROGRAMA DE INSTALACION donde dice EL PROGRAMA DE INSTALACION ESTA CARGANDO LOS COMPONENTES PARA LA INSTALACION. ESTARA LISTO EN UNOS MINUTOS.

a continuacion sale un cuadro que dice INSTALACION DE MICROSOFT .NET FRAMEWORK 3.5 y da la opcion para aceptar la licencia luego acepto y hago click en INSTALAR.

despues sale que lo esta descargando, no se a que se refiere con eso pero eso sale.

luego se empieza a instalar y llega como a los 3/4 de la instalacion y sale que no se pudo instalar por que tuvo un error y no lo puedo se***nstalando.


lo que he intentado para instalarlo es

primero

desinstalarlo con todas las antiguas versiones y instalar cada version una por una y me instala hasta la version 2 y nada mas, despues la 3 no la instala y sale el problema que ya dije anteriormente, tambien e instalado la version 3 sin las antiguas versiones y tampoco instala.

estoy intentando instalar la version 3 por que necesito trabajar con AUTOCAD 2009 y no ***anca el programa sin net framework 3 y si lo ajecuto se abre solo por unos segundos despues sale un cuadrito diciendo que hay un error grave y AUTOCAD 2009 debe cerrarse, e instalado el programa anteriormente en windows vista y nunca paso nada, mi com***dor esta formateado a xp profesional y no tiene ningun error salvo ese que ya les nombre mi xp tiene sp3.

necesito ayuda. GRACIAS.

Pablo Bouzada dijo...

Hola anónimo, en el post tienes una herramienta para hacer una desinstalación completa del .NET Framework. Prueba a usarla e instalar el Framework.

Si no te funciona, busca en el directorio temporal del usuario con el que estás instalando, que tienes que tener algún fichero .LOG con el error concreto que te está dando.

Intelli-CAD dijo...

Vaya, es tan simple que me doy topetasos despues de haber perdido tanto tiempo. Mil gracias por su post!!

seth dijo...

BIEN T FELISITO ME SIRVIO DE MUCHO!!! GRASIAS!!!!!!